Download the Arduino IDE (integrated Development Environment)

Access the Internet

In order to get your Arduino up and running, you'll need to
download some software first from www.arduino.cc (it's
free!). This software, known as the Arduino IDE, will allow
you to program the Arduino to do exactly what you want.
It’s like a word processor for writing programs. With an
interet-capable computer, open up your favorite browser
and type in the following URL into the address bar:

w arduino.cc/en/Main/Software | < casw sensitive >

Click on the “ + ™ sign next to your
appropriate computer operating system.

+ Windows
+ MacOS X
+ Linux: 32 bit, 64 bit

+ source
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c Choose the appropriate Operating System installation package for your computer.



// Connect your Arduino Uno to your Computer

Use the USB cable provided in the USK Kit to connect the
Arduino to one of your computer’s USB inputs.

// Install Drivers

Depending on your computer’s operating system, you will need to follow specific
instructions. Please consult the URLs below for specific instructions on how to
install the drivers onto your Arduino Uno.,

* You will need 1o scroll to the section labeled “Install the drivers”.

Windows Installation Process

Go to the web address below to access the instructions for
installations on a Windows-based computer.

bitp:/sarduino.cc/en/Guide/Windows

Macintosh 0S X Installation Process

Macs do not require you to install drivers. Enter the following URL if
you have questions. Otherwise proceed 1o next page.

butp://arduino.cc/en/Guide/MacOSX

Linux: 32 bit / 64 bit, Installation Process

Go to the web address below to access the instructions for
installations on a Linux-based computer.

bttp://wnow.arduino.ce/playground/Learning/Linux



// Open the Arduino IDE:

Open the Arduino IDE software on your computer. Poke around and get to know
the interface. We aren’t going to code right away, this is just an introduction. The
step is to set your 1DE ro identify your Arduino Uno.




GU' (Graphical User Interface)

1  Verify: Compiles and approves your code. It will catch errors in syntax (like missing semi-coions or parenthesis). ~ See Diagram Below

2 Upload: Sends your code to the Arduino board. When you click it, you should see the lights on your board blink rapidly. See Diagram Below
3 ' New: This buttons opens up a new code window tab.

4 Open: This button will let you open up an existing sketch, See Diagram Below

S ' Save: This saves the currently active sketch.

6 Serial Monitor: This will open a window that displays any serial information your Arduino is transmitting. It is very useful for debugging.
7 Sketch Name: This shows the name of the sketch you are currently working on.

8 Code Area: This is the area where you composa the code for your sketch.

9 Message Area: This is where the IDE telis you if there were any errors in your code.

// The three most important commands for this guide are seen below:

Verify

Upload




// Select your board: Arduino Uno

Auto Format

Archive Sketch

Fix Encoding & Reload
Serial Monitor

Serial Port » Arduino Duemilanove w/ ATmega328)

Arduino Diecimila or Duemilanove w/ ATmega 168
Programmer P | Arduino Nano w/ ATmega32s

Burn Bootloader Arduino Nano w/ ATmega 168

Arduino Mega 2560 or Mega ADK

Arduino Mega (ATmega 280)

Arduino Mini

Arduino Mini w/ATmega 168

Arduino Ethernet

Arduino Fio

Arduino BT w/ ATmega32s

Arduino BT w/ATmega168

LilyPad Arduino w/ ATmega32s

LilyPad Arduino w/ ATmega 168

Arduino Pro or Pro Mini (5V, 16 MH2) w/ATmega328
Arduino Pro or Pro Mini (5V, 16 MHz) w/ATmega168
Arduino Pro or Pro Mini (3.3V, 8 MHz) w/ATmega32s
Arduino Pro or Pro Mini (3.3V, 8 MHz) w/ATmega 168
Arduino NG or older w/ ATmega 168

Arduino NG or older w/ ATmega8

P it ——————————————

Auto Format

Archive Sketch I
Fix Encoding & Reload \
Serial Monitor

| Board »

Select the serial device of the Arduino board from | poorammer | w2 ) |
the Tools | Serial Port menu. This is likely o be l Burn Bootioader

com3 or higher (COMI and COM2 are usually
reserved for hardware serial ports). To find out,
you can disconnect your Arduino board and
reopen the menu; the entry that disappears
should be the Arduino board. Reconnect the board

and select that serial port.
" Auto Format |
0 Archive Sketch
PN Fix Encoding & Reload
' Serial Monitor
| Board L
L Jdevicuusbmodem]62471
Sclect the seral device of the Arduino boand from :::'.‘m"' ® | /devnty Bluetooth Modem
the Tools > Serial Port menu. On the Mac, this - o — :::;mm
sl'u wild be something with /dev/ty.usbmodem Idevicu FireFly-7256-5PP
(for the Uno or Mega 2560) or /dev/tty tiPhone WirelessiAP- |
/dev/uty, boards) in it /dev/cutiPhone WirelessiAP- |
/ity usbserial (for older ) Avsiuy Blestes e POA Syac
/dev/cu Bluetooth-PDA-Sync

hup://www.arduino.cc/playground/Leaming/Linux

A




Download Arduino Code (For use with the circuits in this guide)

// Copy “USK Guide Code” into “Examples” library in Arduino folder

Type in the following URL to download the code:

Q. www.vilros.com/uskcode

o~ !
W

Unzip the file “USK Guide Code”,
It should be located in your
browser's *“Downloads™ folder.
Right click the zipped folder and
choose “unzip™.

%
A

Unzip the file “USK Guide
Code™. It should be loacted in
vour browser’s “Downloads™
folder. Right click the zipped
folder and choose “unzip™.

{) Start —» ) Programs —>» (] arduino —>» ) examples

Copy the “USK Guide Code”™ folder into Arduino’s
folder named “examples”.

ﬁ

Find “Arduino” in your applications
folder. Right click(ctrd + click) on
“Arduino”. Select “Show Package
Contents”,

ehdumo:-* S T S—

Open

Move to Trash

htpy//www.arduino.cc/playground/Lcaming/Linux

8 Contents

'

B8 Resources

v

28 Java

i

38 examples

Copy the “USK Guide Code™
folder into Arduino’s folder
named

“examnles”



Getting Started with Circuits

What is an Electrical Circuit?

A circuit is basically an ¢lectronics loop with a starting
point and an ending point - with any number of compo-
nents in between, Circuits can include resistors, diodes,
inductors, sensors of all sizes and shapes, motors, and any
other handful of hundreds of thousands of components.

Circuits are usually divided into three categories - analog
circuits, digital circuits, or mixed-signal circuits. In this
guide, you will explore all three sets of circuits.

The World Runs on Circuits:

Everywhere you look, vou'll find circuits, The R\
cell phone in your pocket, the computer that
controls your car's emissions system, your
video game console - all these things are chock
full of circuits, In this guide, you'll experiment
with some simple circuits and learn the gist of
the world of embedded electronics,
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// Simple and Complex Circuits

In this guide, you will be primarily exploring
simple circuits - but that doesn't mean you
can't do amazing things with simple tools!
When you've finished the USK, your
knowledge of circuits will enable you to
explore amazing projects and unleash the
power of you imagination,

{l"’"—_[]

auaannEanms

nERRy

::Pl 4{:

Ll B RS X ) SR Bl
D

1

SHNENE NENER NEEEE Snnnn m:nfl ¥
SEERE BRRER anEEnD Sunam anoan

n
n
+4+] n
mi 3
3
a Bl »nnaas 2
un RN 24
+ s R f’
. 71 »RINEIRIes w
b - frdsded »
+ s obecdoe + -

-
i
[







Inventory of Parts

Jumper Wire
Various Colors

llI

l

LED (5mm)
(Light Emitting Diode)

3302 Resistor

i * ACTUAL SIZE

Potentiometer

x1

Photo Resistor

Piezo Element

Temp. Sensor

%

Transistor
(P2N2222AG)

DC Motor

Push Button




x1

Relay

x1

Arduino Board
UNO - SMD Version
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Arduino Uno

Power In (Barrel Jack) - Can be used with either 3 9V or 12V wall-wart or battery.
Power In (USB Port) - Provides power and communicates with your board when plugged into your computer via USB.
_ LED (RX: Recsiving) - This shows when the Arduino is recelving data (such as when being programmed).
LED (Tx: Transmitting) - This shows when your Arduino is transmitting data (such as when running a program),
LED (Pin 13: Troubleshooting) - This LED is incorporated into your sketch to show If your program is running properly,
Pins (ARet, Ground, Digital, Rx, Tx) - These various pins can be used for inputs, outputs, power, and ground. // See Diagram Below
LED (indicates Ardking is ON) - This s a simple power indicator LED,
Reset Button - This is a way to manually reset your Arduino, which makes your code restart.
ICSP Pins (Upicading Code without Bootioader) - This is for *In-Circult Sertal Programming,” used If you want to bypass the boot loader.

Pinswmogmmnﬁrwupmmm - These varfous pins can be used for inputs, outputs, power, and ground. // See Diagram Below

// Pins Diagram
| | 3
/ .
The header pins are one of the most important parts for putting our
example circuits together. Take a moment and locate the input/output
ports of your Arduino Uno.
//’\.\
A Q
- L
| SDA
AREF [l | ARet
— = GND Ground
IOREF s Dy
Reset RESET - e
Power Out 3.3V ::; m
Power Out | [ SV = S
Ground Il GND Q
Ground Guoé S | Dol
@ Powerin [ VIN T 7 Digital
g -l vou
Ansiog Il A0 ° =~ ~-s|ll | Digital
ansiog | [l A1 l Z 4| oo
Analog |l A2 3 s -3l | igea
anciog | [l A3 T 2 oo
ansiog | Il s 2 ™ > 18 | ™x-ou
I M\_AS/::\ '\:} ) RX < 0 j)nx W
v = PWNAnalog out compatible (ie.~3)
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cting electricity to one half or the other.

This line divides the board in half, restr




Breadboard

1 Vertical Connection (+ Power and - Ground /. See Diagram Below)

2 Horizontal Connection (z-e &t

How's it all connected?

-+ See Diagram Below)

PRI I T O I I e I I I ™ .
a o
o o
~ ~
- [
. .
- .
- -
- »

L E R AR RS o EQEC ca= OB NG WA=

3 4+ Power:

Each + sign runs power anywhere in the
vertical column.

== Ground:

Each - sign runs to ground anywhere in the

vertical column.

s Horizontal Rows:

in the same row will be

View of the inside >>>




CIRCUIT #1 - Your First Circuit

How It Works:

1 ASSEMBLE 2 WRITE 3 UPLOAD

(. Make sure the text on the Arduino and
Breadboard are facing up so you can read them.

- -

+ Connect the USB cable.
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+ Peel sticker off back of
Breadboard and stick into place.

5V Current Your Arduino runs on five volts. This is the power that will be supplied from your
computer via USB and will be the driving force behind any components you use in your circuits. By
plugging your Arduino board into your computer, you are supplying it with just the right voltage it
needs to thrive! 5V can't hurt you, so don’t be afraid 1o touch anything in your citcuit.




Pin 13 Arduino

LED
SZ (Light Emitting Diode)

Resistor (3300hm)
(Orange-Orange-Brown)
GND

(ground) (-)

+ This is an illustration of how the

completed circuit should look. It is not

Blinking a LED

LED:s (light-emitting diodes) are small, powerful lights
that are used in many different applications. To start
off the USK, we will work on blinking an LED. That's
right - it's as simple as turning a light on and off. It
might not seem like much, but establishing this
important baseline will give you a solid foundation as
we work toward more complex experiments,

+ Each Circuit begins with a brief description

of the what you are putting together and
the expected result.

+ This section lists the parts you
will need to complete the circuit.

necessary to use the black holder for the + Components like Resistors need

Arduino and Breadboard, but we

to have their legs bent into 90°

recommend it for the first time inventor! X angles in order to correctly fit the

breadboard sockets.
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+ 3300 Resistor: The color banding
should read orange-orange-

brown-gold. The component legs
can go in either hole.
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+ Jumper Wire: All jumper wires
work the same. They are used to

connect two points together. This
guide will show the wires with different
colored insulations for clarity, but using
different combinations of colors is

completely acceptable.
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+ LED: Make sure the short leg,
marked with flat side, goes into
the negative position (-).
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Component: Image Reference:

LED (5mm) /N (¥

3309 Resistor 1 C[[]:D

R " v ) iy

Jumper v_me : A
Jumper Wire

+ Arduino: The blue background
represents a connection to one of
the Arduino header pins.

e2

+ Components like LEDs are inserted into the Breadboard sockets c2{long leg) c3(short leg).

+ Resistors are placed in Breadboard sockets only. The “" symbol represents any socket in its vertical column.

+ “GND" on the Arduino should be connected to the row marked “<" on the Breadboard.

+ "SV” on the Arduino connects 1o the row marked “+" on the Breadboard,

+ “Pin 13" on the Arduino connects to socket “e2” on the Breadboard.

represents a connection to a
breadboard socket.

+ Breadboard: The white background




& Open Your First Sketch:

Open Up the Arduino IDE software on your computer, Coding in the Arduino
language will control your circuit. Open the code for Circuit 1 by accessing the
“USK Guide Code” you downloaded and placed into your "Example” folder carlier.

New
| Open...
Sketchbook >
m_: 1 Basics |
Close 2.Digital >
Save 3.Analog > |
Save As... 4.Communication i3
Upload 5.Control »
Upload Using Progammer 6.5ensors +
" 7.Displays v
Page Setup B.5trings >
| Print ArduinolSP
= = | USKGuideCode P | Circuits1 ==
Circuit #2 :
EEPROM Circuit #3 |
Ethernet Circuit #4
Firmata Circuit #5
Liquid Crystal Circuit #6
SD Circuit #7
Servo Circuit #8
SoftwareSerial Circuit #9
SPI Circuit #10
Stepper Circuit #11
Wire Circuit #12
-y e e  Clrcult #13
Circuit #14
// Circuit #1

' 4
’

.

)

Circuit #1

Blink

one second
repeatedly

on an LED
off for omne

fon

econd

Turns
t ’."h

on

T xample code is in the publis

b )
/

etup() ¢
inditialize the digital pin a
PAn 13 has an LED connected

pintlode(13, OUTPUT);

B 1

on mo

A

malih

out
L

yut
Arduine

boards|




E changes it from text into instructions the computer

your code. The 1D

This compiles 3
can understand.

-

your code automatically.

This sends the instructions via the USB cable to the computer chip on the Arduino board.

The Arduino will then begin running

-

Verify

O

®

S
o.
pua_

ircuit with correct code after verified and uploaded.

// The result of a completed c




+ This is where you will find the

Arduino code for each circuit.

w Open Arduino IDE // File > Examples > USK Guide > Circuit # 1

+ Remember to Verify and
Upload your code.

Code to Note:

+ Begin to understand how the

Arduino code works. See below.

Before you can use one of the Arduino's pins, vou need to tell the
pinMode(13, OUTPUT); :> Arduino whether it is an INPUT or OUTPUT. We use a built-in
"function” called pinMode() to do this,

T - - When you're using a pin as an OUTPUT, vou ¢ and it to be
digitalWrite(13, HIGH): :> \ ’h.ul you're urm.;. 1 pin as an . TPUT ‘\u-u can command it to
HIGH (output 5 Volts), or LOW (output 0 Volts),

+ See if your circuit is complete
and working in this section.

What you Should See:

You should see your LED blink on and off. If
it isn't, make sure you have assembled the
circuit correctly and verified and uploaded the
code to your board or see the troubleshooting
tips below.

+ Here you will find examples of the circuit
you just completed in the real worild.
Many of the theories in these circuits are
used in things you use everyday!

+ This is a section dedicated to the most
common mistakes made while assembling
the circuit.

Troubleshooting: Real World Application:

LED Not Lighting Up? Almost all modern flat screen televisions and monitors
LEDs will only work in one direction. Try taking it out and have LED indicator lights to show they are on or off.
twisting it 180 dgus (no need 10 worry, installing it backwards doos

no permancnt harm).

Program Not Uploading

This happens sometimes, the most likely cause is a confused
serial port, you can change this in wols>serial port>

Still No Success?
A broken circuit is no fun, send us an e-mail and we will get

back 10 you as soon as we can: techsupport@vilros.com




Potentiometer

In this circuit you'll work with a potentiometer.

+5Volts

5 volts across its two outer

s connected with

pins, the middle pin outputs a voltage between 0 and

A potentiometer is also known as a variable resistor.
5, depending on the position of the knob on the

When it

potentiometer. In this circuit, you'll learn how to use

Arduino
Pin AO

)

a potentiometer to control the brightness of an LED.

Potentiometer

Arduino

(Orange-Orange-Brown)

resistor R0chm)

Pin 13

:

——

GND

ground) (-)
E Potentiometer

Wire

or
x1

3300
Resist

,\/)
x1

|7



Circuit 2;: Potentiometer
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* potnonetr -.-,-‘_‘
LED e o ;@@
3300 Resistor : (D !57;
e, | g8
Jumper Wire e _,7—
s e E:-Z
R e 20
Jumper Wire S ————————— -+ .
Jumper Wire T ;

Digital versus Analog:

If you look closely at your Arduino, you'll see some pins labeled "DIGITAL”,
and some labeled "ANALOG". What's the difference?

Many of the devices you'll interface to, such as LEDs and pushbuttons, have
only two possible states: on and off, or as they're known to the Arduino,
"HIGH" (5 Volts) and "LOW™ (0 Volts). The digital pins on an Arduino are
great at getting these signals to and from the outside world, and can even do
tricks like simulated dimming (by blinking on and off really fast), and serial
communications (transferring data to another device by encoding it as patterns

of HIGH and LOW).

ow | <), HiGH
DIGITAL off o |2S on
| ovolts 5 volts

But there are also a lot of things out there that aren’t just "on” or "off".
Temperature levels, control knobs, etc. all have a continuous range of values
between HIGH and LOW. For these situations, the Arduino offers six analog
inputs that translate an input voltage into a number that ranges from 0 (0 Volts)
to 1023 (5 Volts). The analog pins are perfect for measuring all those "real
world” values, and allow you to interface the Arduino to all kinds of things.

0 volts 5 volts

ANALOG 1o




w Open Arduino IDE // File > Examples > USK Guide > Circuit # 2
Code to Note: o o

A "variable"” is a number vou've given a name to. You must
L= : introduce, or "declare” vaniables before vou use them: here we're
int sensorValue; : ' ' " 2 . |
declaring a variable called sensorValue, of type "int” (integer). Don't
forget that vaniable names are casesensitive!

We use the analogRead() function to read the value on an
. . analog pin. analogRead() takes one parameter, the analog
sensorValue = analogRead(sensorPin ); E> . - | -
Pin you want 1o use CsensorPin®), and retums a number
CsensorValue™) between 0 (0 Volts) and 1023 (5 Volts)

The Arduino is very very fast, capable of running thousands of lines
. of code cach second. To slow it down so that we can see what it's
delay(sensorValue); _ & e g ' .
doing, we'll often insert delays into the code. Delay() counts in
milliscconds; there are 1000 ms in one second.

What you Should See:

You should see the LED blink faster
or slower in accordance with your
potentiometer, IFitisn't working,
make sure you have assembled the
circuit correctly and verified and
uploaded the code 1o your board or
see the troubleshooting tips below,

.g:

XN

KN
0000
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&

9

<
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Troubleshooting: Real World Application:

Sporadically Working MP'3 players” volume control is an example of a
This is most likely due to a slightly dodgy connection potentiometer in action,

with the potentiometer's pins. This can usually be
conquered by holding the potentiometer down,

Not Working \ ]l l lT i

Make sure you haven't accidentally connected the U | ’ | 1 ’

potentiometer’s wiper to digital pin 2 rather than analog | e

pin 2. (the row of pins beneath the power pins), '." o~ ;,
| + N\

Still Backward
You can try operating the circuit upside down.
Sometimes this helps. e




RGB LED

Pin 11 Pin 10 Pin9 , z A DA
You know what's even more fun than a blinking
LED? A colored one. RGB, or red-green-blue, LEDs
have three different color-emitting diodes that can be
nm'nlttT combined to create all sorts of colors. In this circuit,
L] » - .
e O e S you'll learn how to use an RGB LED to create unique
" % color combinations. Depending on how bright each
g g d diode is, nearly any color is possible!

—I1— GND
(ground) (-)

LED () 330Q Wire
= Resistor
x3




Circuit 3: RGB LED
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Component:

!‘ Image Reference:

RGBLED smm)  /3\

-l—

e O @G— [4i94)
e —Se— o
3300 Resistor : qin) i-;i
Jumper Wire G hd |
Jumper Wire e —— e /// e5H - I
Jumper Wire G Pin ! E .
Jumper Wire - — = E
Jumper Wire —— o Z |
Jumper Wire e ————————— =

The shocking truth behind analogWrite():

We've seen that the Arduino can read analog voltages (voltages berween 0 and
5 Volts) using the analogRead() function. Is there a way for the Arduino to
output analog voltages as well?

The answer is no... and yes. The Arduino does not have a true analog voltage
output. But, because the Arduino is so fast, it can fake it using something

called PWM ("Pulse-Width Modulation™).

The Arduino is so fast that it can blink a pin on and off almost 1000 times per
second. PWM goes one step further by varying the amount of time that the
blinking pin spends HIGH vs. the time it spends LOW. If it spends most of
its time HIGH, a LED connected to that pin will appear bright. If it spends
most of its time LOW, the LED will look dim. Because the pin is blinking
much faster than your eye can detect, the Arduino creates the illusion of a
"true” analog output.

|

|

) : | |

HIGH (5 volts) = 3 : : ' :
I |g| | I I I | j 05v
LOW (0 volts) > . ‘ :




u Open Arduino IDE // File > Examples > USK Guide > Circuit # 3

Code to Note:

for(x = 0: x <708; x++)

if(x <= 255)

| =
clse

[}

delay(sensorValue); Q

What you Should See:

You should see your LED twurn on,
but this time in new, crazy colors! If it
isn't, make sure you have assembled
the circuit correctly and verified and
uploaded the code 1o your board or
sce the troubleshooting tips below,

Troubleshooting:

A Tor() loop is used 1o step a number across a rnge, and
repeatedly runs code within the brackets (). Here the variable “x”
starts a4 0, ends at 767, and increases by one cach time ("x++7).

I / else” sttements are used 1o make choices in your programs. The
statement within the parenthesis O is evaluated, if it's true, the code within
the first brackets {) will run. IF it's not true, the code within the second

brackets {) will run

The Arduino is very very fast, capable of running thousands of lines
of code cach sccond. To slow it down so that we can see what it's
doing, we'll often insert delays into the code. Delay(O) counts in
milliscconds; there are 1000 ms in one second.

Real World Application:

LED Remains Dark or Shows Incorrect Color Many clectronics such as
With the four pins of the LED so close together, it's videogame consoles use RGB e %
sometimes casy 1o misplace one. Double check each LEDs 1o have the versaility '
pin is where it should be, to show different colors in "
the same arca. Often times
Secing Red the diffent colors represent -
The red diode within the RGB LED may be a bit brighter different states of working
than the other two. To make your colors more balanced, condition, p<
. . . . \/
use a higher ohm resistor, Or adjust in code.
analog Write(RED_PIN, redIntensity);
o

analogWrite(RED_PIN, redIntensity/3);

e



CIRCUIT #4

A4 LED
resiator
R
trma S e & -

=S

Pin 6 Pin7 Pin Pin®

GND
o0
Lo
- - -
ressmtor
B
T - -

L ano

- ot ||

LED ) 330Q Wire
/ Resistor
x8 x8 x10

Multiple LEDs

So you have gotten one LED 1o blink on and off -
fantastic! Now it's time to up the stakes a little bit - by
connecting EIGHT LEDS AT ONCE. We'll also give
our Arduino a little test by creating various lighting
sequences. This circuit is a great setup to start practicing
writing your own programs and getting a feel for the
way Arduino works.

Along with controlling the LEDs, you'll learn about a
couple programming tricks that keep your code neat
and tidy:

for() loops - used when you want to run a piece of
code several times

arrays| ] - used to make managing variables casier by
grouping them together




Circuit 4: Multiple LEDs
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: Component:  Image Reference:

—
cefic 33092 Resistor

“c6!| 3300 Resistor = amD

c8rc?|| 330Q Resistor

i
clifc Jumper Wire
+ -

<cl4rc15||  Jumper Wire
$ =

<l 7hcl Jumper Wire

Jumper Wire

24 | Jumper Wire

DO Jumper Wire

// T o e
-%//M s |
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W Open Arduino IDE // File > Examples > USK Guide > Circuit # 4
Code to Note: O o ;

When vou have to manage a lot of variables, an
. . oot s o “array” is a handy way to group them together. Here
int ledPins{] = {2,3,4,5.6,7.8,9); :> 2 S T L. P 5 _
we're creating an array of integers, called ledPins,
with cight ¢lements.

You refer 1o the clements in an array by their position. The first

E> clement s at position 0, the second is at position 1, ct¢. You reler to

an clement using “ledPins|x|” where x is the position. Here we're

digitalWrite(ledPins[0], HIGH);

making digital pin 2 HIGH, since the armmay clement at position 0 s "2%,

Computers like to do the same things each time they run. But
? : sometimes vou want to do things randomly, such as simulating the
index = random(8); PaRe ) . . g
roll of a dice. The random() function is a great way to do this. Sce
hup://arduino.cc/en/Reference/Random for more information.

What you Should See:

This is similar to circuit number one, but
instead of one LED, you should sce all the
LEDs blink. If they aren’t, make sure you
have assembled the circuit correctly and

verified and uploaded the code to your board

or sce the troubleshooting tips below.

Troubleshooting: Real World Application:

Some LED:s Fail to Light Scrolling marquee displays are gencrally used to spread

It is casy to insert an LED backwards. Check the LEDs short segments of important information. “They are built
that aren't working and ensure they the right way out of many LEDs.

around.

Operating out of sequence

With cight wires it's easy 1o cross a couple. Double check

that the first LED is plugged into pin 2 and cach pin [ o eesee o wes o ooescers oo .
there after. u f"g §:: §“ §“ :.g ::.': §.§ §.; §.. §.§ . 4

Starting Afresh

Its easy to accidentally misplace a wire without noticing,
Pulling everything out and starting with a fresh slate is
often easier than trying to track down the problem.



Pin 13

Pin2 Pin3
+5Volts
resistor

= H H
resistor (330ohm)
(Orange-Orange-Brown)
— GND
- (ground) (-)
Push Button LED 10KQ
Resistor

& .

x2

Push Buttons

Up uniil now, we've focused solely on outputs. Now
we're going to go to the other end of spectrum and
play around with inputs. In this circuit, we'll be
looking at one of the most common and simple
inputs — a push button. The way a push button works
with Arduino is that when the button is pushed, the
voltage goes LOW. The Arduino reads this and reacts
accordingly. In this circuit, you will also use a pull-up
resistor, which helps clean up the voltage and prevents
false readings from the button.

Resistor




Circuit 5: Push Buttons
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‘ How to use logic like a Vulcan:

One of the things that makes the Arduino so uscful is that it can make complex decisions
based on the input it's getting. For cample, you could make a thermostat that tums on a
heater if it gets too cold, a fan if it gets 100 hot, waters your plants if they get too dry, etc.

In order 1o make such decisions, the Arduino provides a sct of logic operations that let you
build complex “if” statements. They incdlude:

== EQUIVALENCE A == Bis true if A and B are the SAME.

= DIFFERENCE A != B s true if A and B are NOT THE SAME. |

&& AND A && B is true if BOTH A and B are TRUE. |
| I OR Al Bis true if A or B or BOTH are TRUE.

I 1 | NOT IA is TRUE if A is FALSE, and FALSE if A is TRUE.

You can combine these functions 1o build complex if{) statements.

For cxample:

if ((mode == heat) && ((temperature < threshold) || (override == truc)))
{

digitalWrite(HEATER, HIGH);

]

..will turn on a heater if you're in heating mode AND the temperature is low, OR if you
turn on a manual override. Using these logic operators, you can program your Arduino to
make intclligent decisions and take control of the world around it!




w] Open Arduino IDE // File > Examples > USK Guide > Circuit # 5
Code to Note: o o

The digital pins can be used as inputs as well as
outputs. Before you do cither, you need to well the
Arduino which direction you're going,

pinMode(button2Pin, INPUT);

To read a digital input, you use the digitalRead ()
button 1State = digitalRead(button 1Pin ); Q function. It will return HIGH i there's SV present it

the pin, or LOW if there's OV present at the pin,

Because we've connected the button to GND, it will read LOW
if (button 1State == LOW) when it's being pressed, Here we're using the "equivalence”
operator ("==") 1o sce il the button is being pressed.

What You Should See:

You should see the LED twurn on
and off as you press the button. If
it isn't working, make sure you
have assembled the circuit correctly
and verified and uploaded the code
to your board or see the
troubleshooting tips below.

Troubleshooting: Real World Application:

Light Not Turning On The buttons we used here are similar to the buttons in
The pushbutton is square, and because of this it is casy to most videogame controllers,

put it in the wrong way. Give it a 90 degree twist and see

if it starts working,

Light Not Fading

A bit of a silly mistake we constantly made, when you / @

switch from simple on off to fading, remember to move {U( )U kﬂ‘ T ( C
the LED wire from pin 13 to pin 9. Q

Underwhelmed

No worries, these circuits are all super stripped down o
make playing with the components easy, but once you
throw them together the sky is the limit.




CIRCUIT #6

Photo Resistor

Pin9 +5 Voits So you've already played with a potentiometer, which
varies resistance based on the twisting of a knob. In
this circuit, you'll be using a photo resistor, which

7 LED ?:soi;?or changes resistance based on how much light the

sensor receives. Since the Arduino can’t directly

interpret resistance (rather it reads voltage), we use a

voltage divider to use our photo resistor. This voltage

% resistor paoehm) —1 Ao divider will output a high voltage when it is getting a

Peetee . lot of light and a low voltage when it is not.

resistor o ot
(Drown- Diach -Orange)

- GND
(ground) ()

Photo Resistor LED 2 330Q Wire 10KQ
= / Resistor Resistor
_ x1 x1 x1 x6 x1




Photo Resistor

Circuit 6
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Photo Resistor
g /A =
33002 Resistor (sensor) (o)
10KS2 Reststor (I

Jumper Wire

Jumper Wire

Jumper Wire
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Jumper Wire
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Measuring resistive sensors:

Many of the sensors you'll use (potentiometers, photoresistors, etc.) are
resistors in disguisc. Their resistance changes in proportion to whatever
they're sensing (light level, etc.).

The Arduino’s analog input pins measure voltage, not resistance. But we can
casily use resistive sensors with the Arduino by including them as part of a

“voltage divider”.

5 volts ——

A voltage divider consists of two resistors. The "top” resistor is the sensor
you'll be using. The "bottom™ one is a normal, fixed resistor. When you
connect the top resistor to 5 Volts, and the bottom resistor to ground, the
middle will output a voltage proportional to the values of the two resistors.
When one of the resistors changes (as it will when your sensor senses things),
the output voltage will change as well!

Although the sensor’s resistance will vary, the resistive sensors (flex
sensor,light sensor, softpot, and trimpot) in the USK are around 10K
Ohms. We usually want the fixed resistor to be close to this value, so using
a 10K resistor is a great choice for the fixed "bottom” resistor.




w Open Arduino IDE // File > Examples > USK Guide > Circuit # 6
Code to Note: 0 °

[:> When we read ananalog signal using analogRead(), it will
be a number from O 1o 1023, But when we wiant to drive i
lightLevel = map(lightLevel, 0, 1023, 0, 255); PWM pin using anadogWeiteO), it wants a number from O to
255, We can "squecze” the larger range into the smaller
range using the mapO) function

E> Because mapO) could still return numbers outside the "to”
range, we'll also use a function called constrain) that will

lightLevel = constrain(lightLevel, 0, 255); clip” numbers into a range. If the number is outside the
rnge, it will make it the largest or smallest number, If it is

within the mnge, it will stay the same

What You Should See:

You should see the LED grow brighter
or dimmer in accordance with how
much light your photoresistor is
reading, 1Ficisn't working, make sure
you have assembled the circuit
correctly and verified and uploaded
the code to your board or see the
troubleshooting tips below.

Troubleshooting: Real World Application:

LED Remains Dark A street lamp uses a light sensor to detect when to turn
This is a mistake we continue to make time and time the lights on at night.

again, if only they could make an LED that worked both

ways. Pullic up and give iva owist,

It Isn't Responding to Changes in Light < - \( —
Given that the spacing of the wires on the photo-resistor ,/’/ .
is not standard, it is easy to misplace it. Double check it's /

in the right place,

Still Not Quite Working

You may be in a room which is cither oo bright or dark,
T'ry turning the lights on or off to see if this helps. Or if
you have a flashlight near by give that a ury.



Pin AO

® +5 Volts
gy
+5v TMP36
signal (precision
gnd temperature
sensor)
—
— GND
— (ground) ()

Temperature Sensor

A temperature sensor is exactly what it sounds like - a
sensor used to measure ambient temperature. This
particular sensor has three pins - a positive, a ground,
and a signal. For every centigrade degree it reads, it
outputs 10 millivolts. In this circuit, you'll learn how to
integrate the temperature sensor with your Arduino,
and use the Arduino IDE’s debug window to display
the temperature.

When you're building the circuit be carcful
not to mix up the temperature sensor and the

transistor, they're almost identical.
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Circuit 7: Temperature Sensor
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{ Component: Image Reference: = Opening your serial monitor:
Temperature Sensor E sfle}i| This circuit uses the Arduino IDE's serial monitor. To open this, first upload the
| ,/ | program then click the button which looks like a magnifying glass in a square.
' Jumper Wire B e /// i5H =
ﬁ =N
| Jumper Wire o u—— '
Jumper Wire B /// |7 - +
i Jumper Wire I +
Jumper Wire L e—— i ]

& Autoscroll No line ending 8 (9600 baud E




W Open Arduino IDE // File > Examples > USK Guide > Circuit # 7
Code to Nole; o o

Before using the serial monitor, you must call Serial. beginO to
: ’ initialize it. 9600 is the "baud rate”, or communications speed.
Serial.begin(9600): % . . :
When two devices are communicating with cach other, both
must be set to the same speed.

The Serial.printQ) command is very smart. It can print out almost

: : anything you can throw at it, including variables of all types,
Serial.print(degreesC); T
quoted text (AKA "strings”), etc,

See buipssarduino oc/en/Serial/Print for maore info

Serial.print() will print everything on the same line. Serial printing)
Serial.printin(degreesy); will move to the next line. By using both of these commands
together, you can create casy-4o-read printouts of text and data,

What You Should See:

You should see be able to read the
(eMperature your temperature
sensor is detecting on the serial
monitor in the Arduino IDE. If it voltage: 0.73 dog C: 22.75 deg F. 7296

isn't working, make sure you have voRago: 0.73 dog C: 2275 deg F: 7296

assembled the circuit correctly and
o vollage: 0.73 dog C. 2275 deg F. 7208
verified and uploaded the code 1o

your board or see the troubleshoot- volago: 0.73 dog C: 2275 dog F. 7290
ing tips below. volage: 0.73 deg C: 22.75 deg F. 7296

Troubleshooting: Real World Application:

Nothing Scems to Happen Building climate control systems use a temperature sensor
This program has no outward indication it is working, To to monitor and maintain their settings.

see the results you must open the Arduino IDE's serial

monitor (instructions on previous page).

Gibberish is Displayed
This happens because the serial monitor is receiving data at
a different speed than expected. To fix this, dick the

Ve " * o
pull-down box that reads "*** baud” and change it to 68
"9600 baud”,

Temperature Value is Unchanging
Try pinching the sensor with your fingers 1o heat it up or
pressing a bag of ice against it to cool it down,



pulse of voltage a servo receives, you can
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you'll learn how to use PWM (pulse width

modulation) to control and rotate a servo.
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because they do one thing very well that spinning motors
cannot — they can move 1o a position accurately. By

varying the

Servos are ideal for embedded clectronics applications
move a servo 1o a specific position. For example, a pulse
of 1.5 milliscconds will move the servo 90 degrees. In this

A Single Servo

circuit
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Expand your horizons using Libraries:

Component: Image Reference: _E‘
Servo c::%:::) . 05806 o7
Jumper Wire e5-@
Jumper Wire V/ ﬁ'[’
Jumper Wire — D —— @"[9]
Jumper Wire e Y —— W {;7]
Jumper Wire R — E{JL;
Jumper Wire === S L°°_}'IL*]
Jumper Wire B [ )
:lumpef Wire | EEE—— ] =]

Arduino gives you a very useful set of built-in commands for doing basic input and outpu,
making decisions using logic, solving math problems, etc. But the real power of Arduino is
the huge community using it, and their willingness to share their work.

Librarics are collections of new commands that have been packaged together to make it casy
to include them in your sketches. Arduino comes with a handful of useful libraries, such as
the servo library used in this example, that can be used to interface 10 more advanced
devices (LCD displays, stepper motors, cthernet ports, etc.)

See hetp: //arduino.cc/en/Reference/Libraries for a list of the standard libraries and

information on using them.,

But anyone can create a library, and if you want 1o use a new sensor or output device,
chances are that someone out there has already written one that interfaces that device to the
Arduino. Many of Vilros's products come with Arduino libraries, and you can find even
more using Google and the Arduino Playground at hup://arduino.cc/playground/. And
when YOU get the Arduino working with a new device, consider making a library for it and
sharing it with the world!

To use a library in a sketch, select it from Sketch > Import Library.

Verify / Compile

Show Sketch Folder
Add File...

EEPROM
Ethernet
Firmata
LiquidCrystal
SD

Servo
SoftwareSerial
SP1

Stepper

Wire
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(V1

#include is a special "preprocessor” command that inserts a library
(or any other file) into your sketch. You can type this command
yourself, or choose an instatled library from the “sketch /7 import
library” menu,

Code lo Note:

ginclude <Servo h> :>

The servo library adds new communds that let you control a servo.

E> To prepare the Arduino to control a servo, vou must first create a
Servo "object” for cach servo (here we've named it “servol™), and
then "actach” it to a digital pin (here we're using pin 9).

SCIrvo servol:

servo Lattach(v):

Servos don't spin all the way around, but they can be commanded o move to
; A specilic position, We use the servo library's write() command to move a
servo Lwreite( 180 ) .
servo 1o a specificd number of degrees(O 1o 180), Remember that the servo

requires tme 1o move, so give it a short delayO if necessary.

What You Should See:

S /‘: ’;;;623¢$z°z<,
You should see your servo motor move to LIS SSSs
) ' . 0 " '..: ’¢¢°¢¢¢¢°¢¢
various locations at several speeds. If the e e
motor doesn’t move, check your RO DI <

connections and make sure you have
verified and uploaded the code, or see the
troubleshooting tips below.

Troubleshooting:

Servo Not Twisting
Even with colored wires it is still shockingly casy to plug a
servo in backward. “This might be the case,

Still Not Working

A mistake we made a time or two was simply forgetting
to connect the power (red and brown wires) 1o +5 volts
and ground.

Fits and Starts

If the servo begins moving then twitches, and there's a
flashing light on your Arduino board, the power supply
you are using is not quite up to the challenge. Using a
wall adapter instead of USB should solve this problem.

Real World Application:

Robotic arms you might sec in an assembly line or sci-fi
movie probably have servos in them.,




CIRCUIT# 9

Pin9

Piezo
—— Element

e (NI

— (ground) (-)

x4

In this circuit, we'll again bridge the gap between the
digital world and the analog world. We'll be using a
buzzer that makes a small "click™ when you apply
voltage to it (try it!). By itself that isn't terribly
exciting, but if you turn the voltage on and off
hundreds of times a second, the buzzer will produce a
tone. And if you string a bunch of tones together,
you've got music! This circuit and sketch will play a
classic tune. We'll never let you down!

+ If the buzzer doesn't easily fit
into the holes on the breadboard,
try rotating it slightly.
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Component:

Piezo Element

Image Reference:

Jumper Wire

Jumper Wire

Jumper Wire

Jumper Wire

Creating your own functions:

Arduino contains a wealth of built-in functions that are useful for all kinds of things.
(See hupi//arduino.cc/en/Reference for a list). But you can also easily create your
own functions. Here's a simple example named "add”, which adds two numbers
together and returns the result. Let's break it down,

int add(int parameterl, int parameter2)
I
int x;

x = parameter] + parameter2;

return(x);

Your functions can take in values ("parameters”), and return a value, as this one does.
But you can also do cither or none of those things, if you wish.

If you'll be passing parameters /to/ your function, put them (and their types) in the
. L . .
parentheses after the function name. If you won't be giving your function any
parameters, just use an empty parenthesis () after the name.

If you'll be returning a value /from/ your function, put the type of the return value in
front of the function name. Then in your function, when you're ready to return the
value, put in a return() statement. If you won't be returning a value, put “void” in
front of the function name (just like you've already seen for the setup() and loop()
functions).

When you write your own functions, you make your code neater and easier to re-use,
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Code to Note: 0 o

Up until now we've been working solely with numenical

data, but the Arduino can also work with text. Characters
Q (single, printable, letters, numbers and other symbols) have

their own type, called “char”. When you have an ammay of

char notesl|] = "cdfda ag cdfdg gf ";

char names{] = ['¢','d",'e','f,'g,'a' D" ,'C; - .
=1 & characters, it can be defined between doublequotes (also

called a “string”™), OR as a list of singlequoted chamcters

One of Arduino’s many useful built-in commands is the
tone() function. This function daves an output pin at a
certain frequency, making it perfect for driving buzzers and
tone( pin, frequency, duration); © speakers. If you give it a duration (in milliscconds), it will
play the tone then stop. If you don't give it a duration, it
will keep playving the tone forever (but you can stop it with

another function, noTonc) ).

What You Should See:

You should see - well, nothing!
But you should be able to hear
you piczo element playing
"Twinkle, Twinkle Litde Star” (or
possibly, “The ABCs”). If it isn't
working, make surc you have
assembled the circuit correctly and
verified and uploaded the code 1o
your board or see the
troubleshooting tips below.

Al

Troubleshooting: Real World Application:

No Sound Many modern megaphones have scttings that use a loud
Given the size and shape of the piczo clement it is casy 10 amplified buzzer. They are usually very loud and quite
miss the right holes on the breadboard. Try double good at getting people’s attention.

checking its placement.

Can't Think While the Mclody is Playing
Just pull up the piczo dement whilst you think, upload
your program then plug it back in. 000

Tired of Twinkle Twinkle Little Star

The code is written so you can casily add your own songs.



CIRCUIT # 10

Spinning a Motor

FOSISIOfn (X200 Remember before when you played around with a servo
motor? Now we are going to tackle spinning a motor.
base This requires the use of a transistor, which can switch a
/Wﬁ larger amount of current than the Arduino can. When
= e using a transistor, you just nced to make sure its
maximum specs are high enough for your use. The
transistor we are using for this circuit is rated at 40V max
e and 200 milliamps max — perfect for our oy motor!
& e
AVAY - g GND
: 2 foround (-
= When you're building the circuit be carcful
A not 1o mix up the transistor and the

temperature sensor, they're almost identical.

+5 volts




Circuit 10 : Spinning a Motor
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Putting it all together:

Component: lmage Reference:
Transistor p2nz22246 § / L;L‘ﬁf??};??;
Diode 1148 [~b7 =bll
DC Motor ﬁll)- 271 el
330Q Resistor // €2 7 g2
|
Jumper Wire B — // ;T?
Jumper Wire O e R f
Jumper Wire e —— o7 "'_ % !
Jumper Wire - o— —-— e3 - di |
Jumper Wire ' -+ |
Jumper Wire ) |

At this point you're probably starting to get your own ideas for circuits that do fun
things, or help solve a real problem. Excellent! Here are some tips on programming in

general.

Most of the sketches you write will be a loop with some or all of these steps:

1. Perform some sort of input
2. Make some calculations or decisions
3. Perform some sort of output

4. Repeat! (Or not!)

We've already shown you how 1o use a bunch of different input sensors and output
devices (and we still have a few more to go). Feel free to make use of the examples in
your own sketches - this is the whole idea behind the "Open Source™ movement.

It's usually pretey casy to pull picces of different sketches together, just open them in
two windows, and copy and paste between them. This is one of the reasons we've
been promoting “good programming habits™. Things like using constants for pin
numbers, and breaking your sketch into functions, make it much casier to re-use your
code in new sketches, For example, if you pull in two pieces of code that use the same
pin, you can casily change onc of the constants to a new pin. (Don't forget that not

all of the pins support analogWrite(): the compatible pins are marked on your board.)

If you nced help, there are internet forums where you can ask questions. Try
Arduino’s forum at arduino.cc/forum, and Vilros's at forum.vilros.com.

When you're ready to move to more advanced topics, take a look at Arduino's
tutorials page at arduino.cc/en/Tutorial. Many of Vilros's more advanced
products were programmed with Arduino, (allowing you to casily modify them), or
have Arduino examples for them. See our product pages for info.

Finally, when you create something really cool, consider sharing it with the world so
that others can learn from your genius. (And be sure to let us know so we can put it
on our home page!)
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Code to Note:

=

while (Serial.available() > 0)

=

speed = Serial.parselnt();

What You Should See:

The DC Motor should spin if you have
assembled the circuit’s components correctly,
and also verified/uploaded the correct code. If
your circuit is not working check the
troubleshooting section below.

Troubleshooting:

Motor Not Spinning

If you sourced your own transistor, double check with
the data sheet that the pinout is compatible with a
P2N2222AG (many are reversed).

Still No Luck

If you sourced your own motor, double check thar it will
work with 5 volts and that it does not draw oo much
power,

Still Not Working

Sometimes the Arduino board will disconnect from the
computer. Try un-plugging and then re-plugging it into
your USB port.

0O

The Arduino's serial port can be used to receive as well as
send data. Because data could amive at any time, the Arduino
stores, or "buffers” data coming into the pont until you're

ready 1o use it. The Serialavailable() command retums the
number of characters that the port has reccived, but havent
been used by vour sketch yet. Zero means no data has amived.

If the port has data waiting for you, there are a number of
ways for you 1o use it. Since we're typing numbers into the
port, we can use the handy Serial. parscint() command to
extract, or “pane” integer numbers from the chamctens it's
received, If you type *17 707 707 1o the port, this function

will rctum the number 100,

Real World Application:

Radio Controlled(RC) cars use Direct Current(DC)
motors to tmn the wheels for propulsion.




Pin 2

Relays

resistor o
> wgm O g Brvaey
In this circuit, we are going to use some of the lessons we
S base learned in circuit 12 to control a relay. A relay is basically
w” PIN2222AG an clectrically controlled mechanical switch. Inside thar
. m_“’_@ﬂ harmless looking plastic box is an electromagnet that,
i when it gets a jolt of energy, causes a switch to wrip. In
this circuit, you'll learn how to control a relay like a pro
§ — giving your Arduino even more powerful abilities!
g SZ ityback)
5] i3

When the relay is off, the COM (common)

LED LED 2
pin will be connected to the NC (Normally
o Closed) pin. .\\’lu.'n the relay is on, the COM
(common) pin will be connected to the NO
(Normally Open) pin.

Transistor
P2N2ZZZAG ' Resistor

A
i
g.
> ¥
s X

L 8 »
-

X




Relays

Circuit 11
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Component: Component: Image Reference:
3
Relay | E;_E Jumper Wire
Transistor p2nzzz2as | // a2ja3tes|  Jumper Wire |
] / : e ‘
LED (5mm) / cl9nc20 Jumpe:Wire B EEEEEEEEEE— R //
A o
A e // -]
| +
Diode 144148 ; ?E Jumper Wire s - o
| ! 7/ —
330Q Resisto : ﬁi Jumper Wire m—— = Led'.GQ
7
3300 Resisto : // e24g2||  Jumper Wire g
T
Jumper Wire 2" Jumper Wire
54— —
Jumper Wire Pin 2 i3: |
—_—
Jumper Wire 57'i9‘1
Jumper Wire '_h9-: + ||

15 19‘
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Code to Note;

=

digitalWrite(relayPin, HIGH);

digitalWrite(relayPin, LOW);

What You Should See:

You should be able to hear the
relay contacts click, and see the
two LEDs alternate illuminating
at 1-second intervals. If you
don't, double-check that you
have assembled the circuit
correctly, and uploaded the
correct sketch 1o the board. Also,
sce the troubleshooting tips below,

Troubleshooting:

LEDs Not Lighting

Double-check that you've plugged them in correctly. The
longer lead (and non-flat edge of the plastic flange) is the
positive lead.

No Clicking Sound

The transistor or coil portion of the circuit isn't quite

working. Check the transistor is plugged in the right way.

Not Quite Working
The incdluded relays are designed to be soldered rather than
used in a breadboard. As such you may need 1o press it in

to ensure it works (and it may pop out occasionally).

0O

When we tum on the transistor, which in tum enengizes

the relay’s coil, the refay’s switch contacts are closed. This
connects the relay’s COM pin to the NO (Normally Open)
pin. Whatever you've connected using these pins will tum

on. (Here we're using LEDs, but this coukd be almost amvihing )

e relay has an additional contact called NC (Normally
Closed). The NC pin is connected to the COM pin when
the relay is OFF. You can use cither pin depending on
whether something shoukd be normally on or nomully off

You can also use both pins to altermate power 1o two

devices, much like milroad crossing waming lights

Real World Application:

Garage door openers use relays to operate. You might be
able 1o hear the dicking if you listen closcly.




Shift Register
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S ety DN I I ) Now we are going to step into the world of ICs (integrated
A1 18 ¥ 10 = | circuits). In this circuit, you'll keamn all about using a shift
: o Lseet | [T ] register (also called a serial-to-paralle] controller). The shift
=5 I S register will give your Arduino an additional eight ourputs,
e W———1 2 12 . "]" ' using only three pins on your board. For this circuit, you'll
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~ Component (1] Component: Image Reference: f[;ﬂ
c A\ | .: I,, = n:,:: ::;] Jumper Wire e —
LED (5mm) A\ 52 W @Ef Jumper Wire S — — //// [isH + ]
LED (Somry A | p @fﬂ_"] Jumper Wire G —— ”.Z ;ﬁ
LED (mm) A\ | < % [?ﬁ]‘[dj‘ Jumper Wire e ——— e 7
LED (smm) AN e //// 224 | Jumper Wire B SR 8K~
LED (smm) _'__ 3 ///// L“!‘J ",] Jumper Wire  eE——— e 9
LED (smm) /_/'\Q. i [WJ L'!"’J Jumper Wire B e I i10
LED (smm) A ¥ "3‘9 w21| | Jumper Wire X = s+
LED (5mm) A Y [@}(6& Jumper Wire - c— —-— W-w
330Q Resistor | { - kals||  Jumper Wire e //// Wf ?)"
330Q Resistor :'m Jumper Wire L G /// 56 w
330Q Resistor L; Io2—l' Jumper Wire e —————— m oll
3300 Resistor - Fa2a||  Jumper Wire S ———— ’//// 23 07|
3300 Resistor '.Ts—}*i Jumper Wire | e // 020 oé
330Q Resistor // ]E-j Jumper Wire - e // :o|7_ loS |
330Q Resistor /// }rp_l'-{_-J Jumper Wire  e— e I////////// alds j6 |
330Q Resistor // [p?r? Jumper Wire = ——— | + |

L Jumper Wire W/////; 1]-1 0_1‘ Jumper Wire  —




w] Open Arduino IDE // File > Examples > USK Guide > Circuit # 12
Code to Note: 0 °

© You'll communicate with the shift register (and 2 Jot of other parts)
using an intcrface calied SPL or Scrial Peripheral Interface. This
. o . o S interface wses a data line and a separate dock ine that work together
shiftOut(datapin, clockpin, MSBFIRST, data); P - o
t0 move data in or out of the Arduino at high speod. The MSBFIRST
paramcter specifios the order in which 1o send the individual bits, in

this Case we'ne sending the Most Significant Bit firse

© Hits arc the smalicst possible picoe of memony i a competer; cxch
one can store oither 2 717 or 2 07, Langer numbers ane stored as amrays
- A . ) i of bits. Somctimes we want 1o manipulste these bits discoty, for
bitWrite(data,desiredPin, desiredState); : ,
example now whon we'ne sending cight bits to the shift rogister amnd

we want 1o nuke thoem 1 oe 0 10 tum the LEDs on or off. The Andhuino

s several commuands, such as bitWrite(), that muke this casy 10 do

What You Should See:

You should sce the LEDs light up
similarly to in circuit 4 (but this
time, you're using a shift register).
If they aren't, make sure you have
assembled the circuit correctly
and verified and uploaded the
code to your board, or sce the
troubleshooting tips below.
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Troubleshooting: Real World Application:

The Arduino's power LED goes out Similar to circuit #4, a scrolling marquee display delivers
This happened to us a couple of times, it happens when a mesage with multiple LEDs. Essendally the same task
the chip is inserted backward. If you fix it quickly the shift register achicves here in Circuit #12.

nothing will break.

Not Quite Working
Sorry to sound like a broken record but it is probably

somcthing as simple as a crossed wire. —_— —
@ S BEE B B REE 8B aee see

‘ .- s - - - . - -e e e

s e e e o oo oo oo o
Fmstrat:on R SRS SRR ARe e TR

e

Shoot us an e-mail, this circuit is both simple and
complex at the same time. We want 1o hear about
problems you have so we can address them in

future editions: techsupport@vilros.com
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